summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5f38fd580e..5278718f1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -392,6 +392,7 @@ malloc.h \
monetary.h \
netdb.h \
poll.h \
+pty.h \
pwd.h \
resolv.h \
strings.h \
@@ -560,7 +561,6 @@ getgrnam_r \
getpwuid_r \
getwd \
glob \
-grantpt \
inet_ntoa \
inet_ntop \
inet_pton \
@@ -572,7 +572,6 @@ mmap \
nice \
nl_langinfo \
poll \
-ptsname \
putenv \
scandir \
setitimer \
@@ -588,7 +587,6 @@ strptime \
strtok_r \
symlink \
tzset \
-unlockpt \
unsetenv \
usleep \
utime \
@@ -713,6 +711,9 @@ if test "$PHP_VALGRIND" != "no"; then
fi
fi
+dnl Check for openpty. It may require linking against libutil.
+PHP_CHECK_FUNC(openpty, util)
+
dnl General settings.
dnl ----------------------------------------------------------------------------
PHP_CONFIGURE_PART(General settings)