summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikita Popov <nikita.ppv@gmail.com>2020-02-18 16:17:34 +0100
committerNikita Popov <nikita.ppv@gmail.com>2020-02-18 16:17:56 +0100
commit9d31a42a30e944688c29aefc4bd0396ce395efe1 (patch)
tree68ade61e318dbdb264ac65189b02e9b1abfe59c5 /configure.ac
parentf6fcc5c3535c280b76fd8a533bc5eb3f489e9107 (diff)
downloadphp-git-9d31a42a30e944688c29aefc4bd0396ce395efe1.tar.gz
Don't use VLA in mysqlnd auth
We use alloca instead of VLA. This should also allow building this code on Windows.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 501730ba47..f7fb19eff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -737,20 +737,6 @@ if test "$ac_cv__asm_goto" = yes; then
AC_DEFINE(HAVE_ASM_GOTO,1,[Define if asm goto support])
fi
-dnl Check for variable length array support.
-AC_CACHE_CHECK([whether compiler supports VLA], ac_cv__compiler_c99_vla,
-[AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <stdlib.h>
- int main(void) {
- int i[rand()%10];
- return 0;
- }
- ]])],[ac_cv__compiler_c99_vla=yes], [ac_cv__compiler_c99_vla=no], [ac_cv__compiler_c99_vla=no])])
-
-if test "$ac_cv__compiler_c99_vla" = yes; then
- AC_DEFINE(HAVE_COMPILER_C99_VLA, 1, [Compiler supports VLA])
-fi
-
dnl Check valgrind support.
PHP_ARG_WITH([valgrind],
[whether to enable valgrind support],