summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kluyver <takowl@gmail.com>2013-10-26 23:17:28 -0700
committerThomas Kluyver <takowl@gmail.com>2013-10-26 23:17:28 -0700
commitcc3438bcaad01309831bd17cd0e9a62fa78ed2a5 (patch)
treeaafe2889500c1853c55b7de7065912b230433b15 /setup.py
parentb800dc365249498db7bfa9bc4ffa1a40760787d1 (diff)
downloadpexpect-git-cc3438bcaad01309831bd17cd0e9a62fa78ed2a5.tar.gz
Update setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 7 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2fe404a..473c313 100644
--- a/setup.py
+++ b/setup.py
@@ -6,16 +6,15 @@ setup (name='pexpect',
version=__version__,
py_modules=['pxssh', 'fdpexpect', 'FSM', 'screen', 'ANSI'],
packages=['pexpect'],
- description='Pexpect is a pure Python Expect. It allows easy control of other applications.',
+ description='Pexpect allows easy control of interactive console applications.',
author='Noah Spurrier',
author_email='noah@noah.org',
- url='http://pexpect.sourceforge.net/',
+ url='http://pexpect.readthedocs.org/',
license='ISC license',
platforms='UNIX',
classifiers = [
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Environment :: Console',
- 'Environment :: Console (Text Based)',
'Intended Audience :: Developers',
'Intended Audience :: System Administrators',
'Intended Audience :: Quality Engineers',
@@ -23,6 +22,9 @@ setup (name='pexpect',
'Operating System :: POSIX',
'Operating System :: MacOS :: MacOS X',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
'Topic :: Software Development',
'Topic :: Software Development :: Libraries :: Python Modules',
'Topic :: Software Development :: Quality Assurance',
@@ -30,6 +32,6 @@ setup (name='pexpect',
'Topic :: System, System :: Archiving :: Packaging, System :: Installation/Setup',
'Topic :: System :: Shells',
'Topic :: System :: Software Distribution',
- 'Topic :: Terminals, Utilities',
+ 'Topic :: Terminals',
],
)