summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTim Waugh <twaugh@redhat.com>2015-01-28 17:10:23 +0000
committerAndreas Gruenbacher <agruen@gnu.org>2015-01-31 22:13:44 +0100
commit025a54b789bd88ed15430f8633514e296826983e (patch)
tree13eb60f2fe8202f628839c03d4f87214ae25fc47 /tests/Makefile.am
parent6a56d401d29e30eaad31a7e9cf9e493a5a535f8a (diff)
downloadpatch-025a54b789bd88ed15430f8633514e296826983e.tar.gz
Add symlink-safe system call replacements
Add wrappers around system calls that traverse relative pathnames without following symlinks. Written by Tim Waugh <twaugh@redhat.com> and Andreas Gruenbacher <agruenba@redhat.com>. * src/safe.h: Declare functions here. * src/safe.c: Implement safe_* system call replacements that do not follow symlinks along pathnames. Pathname components are resolved with openat(). Lookup results are cached to keep the overhead reasonably low. * tests/deep-directories: New path traversal cache test. * src/Makefile.am (patch_SOURCES): Add safe.[ch]. * tests/Makefile.am (TESTS): Add new test.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cfc4f37..7c9efa9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -52,7 +52,8 @@ TESTS = \
remember-reject-files \
remove-directories \
symlinks \
- unmodified-files
+ unmodified-files \
+ deep-directories
XFAIL_TESTS = \
dash-o-append