summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2009-03-20 19:11:22 +0100
committerAndreas Gruenbacher <agruen@suse.de>2009-03-22 13:36:53 +0100
commite0a0b12a4212cf93b50fe2ec049f5046b99022c2 (patch)
tree155c8f0dbc17a8a0244fb75a7d693e9dffeef09f /configure.ac
parent704083c7bd839befff51eb852890dacc46487c15 (diff)
downloadpatch-e0a0b12a4212cf93b50fe2ec049f5046b99022c2.tar.gz
Compute PACKAGE_VERSION automatically from the repository
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9959a55..d8b2a40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,12 @@
# 02110-1301, USA.
AC_PREREQ(2.57)
-AC_INIT(patch, 2.5.9, bug-patch@gnu.org)
+define(AC_PACKAGE_VERSION, m4_normalize(esyscmd(
+[
+ . update-version.sh VERSION
+ cat VERSION
+])))
+AC_INIT(patch, AC_PACKAGE_VERSION, bug-patch@gnu.org)
AC_CONFIG_SRCDIR(patch.c)
AC_CONFIG_HEADER(config.h:config.hin)
AC_ARG_PROGRAM