summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-10-09 11:40:42 +0200
committerJim Meyering <meyering@redhat.com>2011-12-14 16:34:45 +0100
commit5cb38ce3903b5c33750cd52f983a8f68f945c7dd (patch)
tree8860b967c0cb2ee11834cbb5c01988c44f9e1141 /configure.ac
parent5ca55b84143a840218bcdc78120b44b02d8ef561 (diff)
downloadpatch-5cb38ce3903b5c33750cd52f983a8f68f945c7dd.tar.gz
build: update to latest gnulib and adapt
Mark functions as pure of const, per recommendations enabled by new gcc -W options. Apply _GL_ATTRIBUTE_PURE and _GL_ATTRIBUTE_CONST. * src/common.h: Apply new function attributes. * src/pch.c: Likewise. * src/pch.h: Likewise. * src/util.c: Likewise. * src/util.h: Likewise. * configure.ac: Use -Wno-format-nonliteral. * m4/.gitignore: Update. * gnulib: Update to latest. * cfg.mk: Exempt src/util.c from two tests, to avoid new "make syntax-check" failures.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08aa9ed..20fe5b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,7 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-fdiagnostics-show-option])
gl_WARN_ADD([-funit-at-a-time])
+ gl_WARN_ADD([-Wno-format-nonliteral])
AC_SUBST([WARN_CFLAGS])