summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-07-27 15:42:31 +0200
committerStef Walter <stefw@collabora.co.uk>2011-07-27 15:42:31 +0200
commitdaec3faa85c4f463e3b13688f2bc2bbd1b2ae106 (patch)
treeb128e25581ffb8e997b89b539640f5038f235ceb /configure.ac
parentfb0952dbeb607542b7feab80b1bbd2b1258cd15f (diff)
downloadp11-kit-daec3faa85c4f463e3b13688f2bc2bbd1b2ae106.tar.gz
Add libtool style versioning variables to p11-kit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5548117..26e86fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,19 @@ AC_INIT([p11-kit],
[p11-kit],
[http://p11-glue.freedesktop.org/p11-kit.html])
+dnl ****************************************************************************
+dnl p11-kit libtool versioning
+dnl CURRENT : REVISION : AGE
+dnl +1 : 0 : +1 == new interface that does not break old one.
+dnl +1 : 0 : 0 == removed an interface. Breaks old apps.
+dnl ? : +1 : ? == internal changes that doesn't break anything.
+
+P11KIT_CURRENT=0
+P11KIT_REVISION=0
+P11KIT_AGE=0
+
+dnl ****************************************************************************
+
AC_CONFIG_SRCDIR([p11-kit/modules.c])
AC_CONFIG_HEADERS([config.h])
@@ -156,6 +169,9 @@ fi
# ---------------------------------------------------------------------
+P11KIT_LT_RELEASE=$P11KIT_CURRENT:$P11KIT_REVISION:$P11KIT_AGE
+AC_SUBST(P11KIT_LT_RELEASE)
+
AC_CONFIG_FILES([Makefile
doc/Makefile
doc/version.xml