summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2014-10-02 08:21:28 +0200
committerStef Walter <stefw@redhat.com>2014-10-02 08:24:44 +0200
commit960cb9a7db1950ad1414f70b0e3ec240542601ac (patch)
tree93ca10157b1119fa72bd56165eb00880a943aecf /configure.ac
parentc9474683dd3db5ad87227dd3c3734ab31bfc01e9 (diff)
downloadp11-kit-960cb9a7db1950ad1414f70b0e3ec240542601ac.tar.gz
common: Use secure_getenv() implementation when setuid
In anything security sensitive, use secure_getenv() implementation for retrieving environment variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b316d54..c151c9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,7 +88,7 @@ if test "$os_unix" = "yes"; then
AC_CHECK_HEADERS([sys/resource.h])
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
- AC_CHECK_FUNCS([getauxval issetugid getresuid])
+ AC_CHECK_FUNCS([getauxval issetugid getresuid secure_getenv])
AC_CHECK_FUNCS([strnstr memdup strndup strerror_r])
AC_CHECK_FUNCS([asprintf vasprintf vsnprintf])
AC_CHECK_FUNCS([timegm])