summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cd7a606..9fdb43aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,15 @@ AS_IF([test "$enable_custom_modes" = "yes"],[
AM_CONDITIONAL([CUSTOM_MODES], [test "$enable_custom_modes" = "yes"])
+AC_ARG_ENABLE([neural-fec],
+ [AS_HELP_STRING([--enable-neural-fec], [Use neural FEC for SILK])],,
+ [enable_neural_fec=yes])
+
+AS_IF([test "$enable_neural_fec" = "yes"],[
+ AC_DEFINE([ENABLE_NEURAL_FEC], [1], [Neural FEC])
+ AC_DEFINE([DISABLE_DOT_PROD], [1], [Disable dot product])
+])
+
AC_ARG_ENABLE([neural-plc],
[AS_HELP_STRING([--enable-neural-plc], [Use neural PLC for SILK])],,
[enable_neural_plc=yes])