summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Storsjo <martin@martin.st>2014-03-19 21:36:39 +0200
committerTimothy B. Terriberry <tterribe@xiph.org>2014-03-19 16:33:03 -0700
commit76e831d917fffc55854ba2dc68b61f51c8ba61b7 (patch)
tree254f123494762f044a5725b4acd9825d112a9450 /configure.ac
parentac0e294b52ecc600c05b4b67f74e0f3ccf30a030 (diff)
downloadopus-76e831d917fffc55854ba2dc68b61f51c8ba61b7.tar.gz
Make the arm2gnu.pl converter handle apple specific details
This allows building the arm assembly for iOS. This checks for the __APPLE__ preprocessor built-in define to determine whether this extra handling should be enabled. Signed-off-by: Timothy B. Terriberry <tterribe@xiph.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 443362ff..f427f469 100644
--- a/configure.ac
+++ b/configure.ac
@@ -317,6 +317,14 @@ AS_IF([test x"${enable_asm}" = x"yes"],[
[rtcd_support=ARM"$rtcd_support"],
[rtcd_support="no"]
)
+ AC_MSG_CHECKING([for apple style tools])
+ AC_PREPROC_IFELSE([AC_LANG_PROGRAM([
+#ifndef __APPLE__
+#error 1
+#endif],[])],
+ [AC_MSG_RESULT([yes]); ARM2GNU_PARAMS="--apple"],
+ [AC_MSG_RESULT([no]); ARM2GNU_PARAMS=""])
+ AC_SUBST(ARM2GNU_PARAMS)
],
[
AC_MSG_WARN(