summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRon <ron@debian.org>2013-05-18 16:11:18 +0930
committerRon <ron@debian.org>2013-05-18 16:11:18 +0930
commit918acd1564a38c61f3cb2392d3b38f1539f14eda (patch)
treef4b4e9ef3e9f8d1d23231f85bb286d4beb5306b0 /configure.ac
parentefdd314305038978062e48bdb98bc9d4832eebbf (diff)
downloadopus-918acd1564a38c61f3cb2392d3b38f1539f14eda.tar.gz
Use m4_esyscmd instead of m4_esyscmd_s
We shouldn't ever have any trailing newlines that need trimming here, and the _s version wasn't added to m4sugar.m4 until autoconf 2.63b, so this will let it work with 2.13 again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 03c36c47..060bb523 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,12 +4,12 @@ dnl The package_version file will be automatically synced to the git revision
dnl by the update_version script when configured in the repository, but will
dnl remain constant in tarball releases unless it is manually edited.
m4_define([CURRENT_VERSION],
- m4_esyscmd_s([ if test -e package_version || ./update_version; then
- . ./package_version
- printf "$PACKAGE_VERSION"
- else
- printf "unknown"
- fi ]))
+ m4_esyscmd([ if test -e package_version || ./update_version; then
+ . ./package_version
+ printf "$PACKAGE_VERSION"
+ else
+ printf "unknown"
+ fi ]))
AC_INIT([opus],[CURRENT_VERSION],[opus@xiph.org])