summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJean-Marc Valin <jmvalin@jmvalin.ca>2012-07-05 01:28:45 -0400
committerJean-Marc Valin <jmvalin@jmvalin.ca>2012-07-13 14:50:37 -0400
commitc5880fe48bdeb5ae40ceeb679b9c1a633448fab4 (patch)
tree594a880505348de08ef339a82770af8b2a5a2c99 /Makefile.am
parent5d34794d8f595430c936d5f880a29a9fb4cd7383 (diff)
downloadopus-c5880fe48bdeb5ae40ceeb679b9c1a633448fab4.tar.gz
Builds the analysis files more cleanly than #including C files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3607e522..7a29d54a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,12 +14,9 @@ if FIXED_POINT
SILK_SOURCES += $(SILK_SOURCES_FIXED)
else
SILK_SOURCES += $(SILK_SOURCES_FLOAT)
+OPUS_SOURCES += $(OPUS_SOURCES_FLOAT)
endif
-include celt_headers.mk
-include silk_headers.mk
-include opus_headers.mk
-
libopus_la_SOURCES = $(CELT_SOURCES) $(SILK_SOURCES) $(OPUS_SOURCES)
pkginclude_HEADERS = include/opus.h include/opus_multistream.h include/opus_types.h include/opus_defines.h