summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRon <ron@debian.org>2012-06-12 04:40:42 +0930
committerGregory Maxwell <greg@xiph.org>2012-06-11 15:33:57 -0400
commit9a89d56d46a8d37d32bb40afd9ccf72cb9a80be9 (patch)
treef308868229e6872b5e90f8af6a4bd33ec5d95b8a /Makefile.am
parent99aaff5233b45fd886edffd9a047b85b81a09a53 (diff)
downloadopus-9a89d56d46a8d37d32bb40afd9ccf72cb9a80be9.tar.gz
Include the doc dir in DIST_SUBDIRS instead of EXTRA_DIST
And explicitly specify what we want included in EXTRA_DIST of doc/Makefile.am, otherwise make dist picks up whatever random junk you might have laying around in that dir at the time you run it. Tweak the top level delegation targets, because this means distclean will be run in the doc dir by default now without our help.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f51f51a..3607e522 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@ AUTOMAKE_OPTIONS = subdir-objects
lib_LTLIBRARIES = libopus.la
+DIST_SUBDIRS = doc
+
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/celt -I$(top_srcdir)/silk -I$(top_srcdir)/silk/float -I$(top_srcdir)/silk/fixed
include celt_sources.mk
@@ -79,7 +81,7 @@ opus_custom_demo_SOURCES = celt/opus_custom_demo.c
opus_custom_demo_LDADD = libopus.la -lm
endif
-EXTRA_DIST = opus.pc.in opus-uninstalled.pc.in doc
+EXTRA_DIST = opus.pc.in opus-uninstalled.pc.in
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = opus.pc
@@ -109,10 +111,7 @@ install-data-local:
@[ -n "$(NO_DOXYGEN)" ] || $(MAKE) $(AM_MAKEFLAGS) -C doc install
clean-local:
- $(MAKE) $(AM_MAKEFLAGS) -C doc clean
-
-distclean-local:
- $(MAKE) $(AM_MAKEFLAGS) -C doc distclean
+ -$(MAKE) $(AM_MAKEFLAGS) -C doc clean
uninstall-local:
$(MAKE) $(AM_MAKEFLAGS) -C doc uninstall