summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt1
-rw-r--r--ustream-internal.h3
2 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1c2b32..2ce9bf8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ ELSEIF(CYASSL)
IF (HAVE_CYASSL_VERSION_H)
ADD_DEFINITIONS(-DHAVE_CYASSL_VERSION_H)
ENDIF()
+ ADD_DEFINITIONS(-DHAVE_CYASSL)
SET(SSL_SRC ustream-io-cyassl.c ustream-openssl.c)
SET(SSL_LIB cyassl m)
ELSE()
diff --git a/ustream-internal.h b/ustream-internal.h
index 020e1c6..4932a0d 100644
--- a/ustream-internal.h
+++ b/ustream-internal.h
@@ -26,6 +26,9 @@
#elif defined(HAVE_POLARSSL)
#include "ustream-polarssl.h"
#else
+#if defined(HAVE_CYASSL)
+#include <wolfssl/options.h>
+#endif
#include "ustream-openssl.h"
#endif