summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-25 09:06:36 +0200
committerFelix Fietkau <nbd@openwrt.org>2013-09-25 09:06:36 +0200
commite8ec1e56c3ec71b0eeeeac8842b6519548f3c695 (patch)
tree479ea84427aadce089fa72b2d7ef76b9c787412d
parentdaa954de38f2bf4e2fbc41ac7917f8447d37a2a0 (diff)
downloadustream-ssl-e8ec1e56c3ec71b0eeeeac8842b6519548f3c695.tar.gz
avoid installing internal header files
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1178c62..f6009e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,8 +28,7 @@ TARGET_LINK_LIBRARIES(ustream-ssl ubox ${SSL_LIB})
ADD_EXECUTABLE(ustream-example ustream-example.c)
TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
-FILE(GLOB headers *.h)
-INSTALL(FILES ${headers}
+INSTALL(FILES ustream-ssl.h
DESTINATION include/libubox
)
INSTALL(TARGETS ustream-ssl