summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-27 19:09:41 +0100
committerFelix Fietkau <nbd@openwrt.org>2012-12-27 19:09:41 +0100
commit2aba5bdb1c8b74a4654f46748dc4746434489750 (patch)
treebf968daf7f0f7d9fd2e446a43a015183c2a0ca4b
parent55e2be9640ea22c59d59b29ad61d99e71c9f67b5 (diff)
downloadustream-ssl-2aba5bdb1c8b74a4654f46748dc4746434489750.tar.gz
install headers and library
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd8ce3f..640afce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,3 +25,11 @@ ADD_EXECUTABLE(ustream-example ustream-example.c)
TARGET_LINK_LIBRARIES(ustream-example ustream-ssl)
SET(CMAKE_INSTALL_PREFIX /usr)
+
+FILE(GLOB headers *.h)
+INSTALL(FILES ${headers}
+ DESTINATION include/libubox
+)
+INSTALL(TARGETS ustream-ssl
+ LIBRARY DESTINATION lib
+)