summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-24 10:57:35 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-27 20:57:58 +0200
commit80653f0c07aeef1c0e37c1aad828158f6e47eaee (patch)
tree897ddfbcd4da879e8a035cc411e0eb9dd9972235
parenteeff8b3be101b639dd4d99e50bb0de0a3ae63f7c (diff)
downloadopenwrt-80653f0c07aeef1c0e37c1aad828158f6e47eaee.tar.gz
tools/ccache: update to 4.6.2
Release notes: https://ccache.dev/releasenotes.html#_ccache_4_6_2 Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit ac61cf596cc4cdfb93981361b093c1d97e4a1b96)
-rw-r--r--tools/ccache/Makefile4
-rw-r--r--tools/ccache/patches/100-honour-copts.patch2
-rw-r--r--tools/ccache/patches/110-musl-gcc12.patch4
3 files changed, 5 insertions, 5 deletions
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
index 9d03a6e82c..8c95fc6a50 100644
--- a/tools/ccache/Makefile
+++ b/tools/ccache/Makefile
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
-PKG_VERSION:=4.6.1
+PKG_VERSION:=4.6.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
-PKG_HASH:=e5d47bd3cbb504ada864124690e7c0d28ecb1f9aeac22a9976025aed9633f3d1
+PKG_HASH:=789a2435d7fde2eaef5ec7b3ecf2366e546f764253e9999fdf008d2dd7f3b10c
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/tools/ccache/patches/100-honour-copts.patch b/tools/ccache/patches/100-honour-copts.patch
index 18ded55315..24be22cbf0 100644
--- a/tools/ccache/patches/100-honour-copts.patch
+++ b/tools/ccache/patches/100-honour-copts.patch
@@ -1,6 +1,6 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
-@@ -1754,6 +1754,7 @@ calculate_result_and_manifest_key(Contex
+@@ -1750,6 +1750,7 @@ calculate_result_and_manifest_key(Contex
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
diff --git a/tools/ccache/patches/110-musl-gcc12.patch b/tools/ccache/patches/110-musl-gcc12.patch
index 01229ed475..4e7784dcc8 100644
--- a/tools/ccache/patches/110-musl-gcc12.patch
+++ b/tools/ccache/patches/110-musl-gcc12.patch
@@ -22,9 +22,9 @@ Subject: [PATCH] fix: Fix build with musl when using GCC 12 (#1145)
#include <limits>
--- a/src/core/Statistics.hpp
+++ b/src/core/Statistics.hpp
-@@ -21,6 +21,7 @@
- #include <core/StatisticsCounters.hpp>
+@@ -22,6 +22,7 @@
+ #include <cstdint>
#include <string>
+#include <ctime>
#include <unordered_map>