summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-08-19 18:59:36 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-05 21:50:01 +0200
commitf579b8538b72ed4ea9b53e7ed1cffe651e90ffeb (patch)
treea706d5b06000956962fa2881492d111de0cb9ab1
parent4b5bd1509195bc8f19999ebe481b59356b5c3512 (diff)
downloadopenwrt-f579b8538b72ed4ea9b53e7ed1cffe651e90ffeb.tar.gz
ath79: add low_mem to tiny image
Devices with SMALL_FLASH enabled have "SQUASHFS_BLOCK_SIZE=1024" in their config. This significantly increases the cache memory required by squashfs [0]. This commit enables low_mem leading to a much better performance because the SQUASHFS_BLOCK_SIZE is reduced to 256. Example Nanostation M5 (XM): The image size increases by 128 KiB. However, the memory statisitcs look much better: Default tiny build: ------ MemTotal: 26020 kB MemFree: 5648 kB MemAvailable: 6112 kB Buffers: 0 kB Cached: 3044 kB low_mem enabled: ----- MemTotal: 26976 kB MemFree: 6748 kB MemAvailable: 11504 kB Buffers: 0 kB Cached: 7204 kB [0] - https://github.com/freifunk-gluon/gluon/commit/7e8af99cf504ca1dc389f282a0c94f4a911571be Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit f54ac98f8cec676761e5144ae06640b8007b4b04)
-rw-r--r--target/linux/ath79/tiny/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/tiny/target.mk b/target/linux/ath79/tiny/target.mk
index 91f135b56e..28e02f7a67 100644
--- a/target/linux/ath79/tiny/target.mk
+++ b/target/linux/ath79/tiny/target.mk
@@ -1,5 +1,5 @@
BOARDNAME:=Devices with small flash
-FEATURES += small_flash
+FEATURES += low_mem small_flash
DEFAULT_PACKAGES += wpad-basic-wolfssl