summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-09-30 10:39:23 -0400
committerMonty Taylor <mordred@inaugust.com>2013-09-30 10:39:23 -0400
commit9b7d463f687e8dd8e300cc7196944d8a236777f3 (patch)
treecd7fc0906f6fca704153c49db5d55f4d1627653d /setup.py
parent278e2ba53b3729cd0f70bc4d9db6c61444def846 (diff)
downloadtaskflow-9b7d463f687e8dd8e300cc7196944d8a236777f3.tar.gz
Remove d2to dependency
Change-Id: I433711ba417dbb15f616fa488cec389f3138b00a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 7 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 726cd9c..c0a24ea 100644
--- a/setup.py
+++ b/setup.py
@@ -1,24 +1,21 @@
-# Copyright 2011 OpenStack Foundation
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
import setuptools
-
setuptools.setup(
- setup_requires=[
- 'd2to1>=0.2.10,<0.3',
- 'pbr>=0.5,<0.6'
- ],
- d2to1=True
-)
+ setup_requires=['pbr'],
+ pbr=True)