summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2013-07-07 21:22:34 -0700
committerJoshua Harlow <harlowja@gmail.com>2013-07-07 21:46:32 -0700
commit16c7b8aa19e04a1833d568c8ffde92e2c8945370 (patch)
tree573eb58263214c95b7d015b1601c7bbb25dc6270 /setup.py
parentb89eefea1804ede071747f558bb11571090445b3 (diff)
downloadtaskflow-16c7b8aa19e04a1833d568c8ffde92e2c8945370.tar.gz
Move to using pbr.
The new way to build packages and perform setuptools interactions seems to be via the pbr library so to play well with others, use said library. Change-Id: I519503fdf59457dc554870b8e6ff61613ab30d11
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py60
1 files changed, 18 insertions, 42 deletions
diff --git a/setup.py b/setup.py
index 4c0cdfc..726cd9c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,48 +1,24 @@
-#!/usr/bin/env python
+# Copyright 2011 OpenStack Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
-import os
import setuptools
-def _clean_line(line):
- line = line.strip()
- line = line.split("#")[0]
- line = line.strip()
- return line
-
-
-def read_requires(base):
- path = os.path.join('tools', base)
- requires = []
- if not os.path.isfile(path):
- return requires
- with open(path, 'rb') as h:
- for line in h.read().splitlines():
- line = _clean_line(line)
- if not line:
- continue
- requires.append(line)
- return requires
-
-
setuptools.setup(
- name='taskflow',
- version='0.0.1',
- author='OpenStack',
- license='Apache Software License',
- description='Taskflow structured state management library.',
- long_description='The taskflow library provides core functionality that '
- 'can be used to build [resumable, reliable, '
- 'easily understandable, ...] highly available '
- 'systems which process workflows in a structured manner.',
- author_email='openstack-dev@lists.openstack.org',
- url='http://www.openstack.org/',
- packages=setuptools.find_packages(),
- tests_require=read_requires('test-requires'),
- install_requires=read_requires('pip-requires'),
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python :: 2.6', ],
+ setup_requires=[
+ 'd2to1>=0.2.10,<0.3',
+ 'pbr>=0.5,<0.6'
+ ],
+ d2to1=True
)