summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNikita Konovalov <nkonovalov@mirantis.com>2013-07-23 11:39:58 +0400
committerNikita Konovalov <nkonovalov@mirantis.com>2013-08-02 23:03:47 +0400
commitf8163866fb2086a574125b7b380dba54b7c74dee (patch)
treec9e0382a429750efaff01cd70b075ecb57eda4c7 /setup.py
parent0f4f63b1145a10ddc476e5c4f8cbf48208cd7193 (diff)
downloadpython-saharaclient-f8163866fb2086a574125b7b380dba54b7c74dee.tar.gz
Python Savanna Client initial implementation
Image Registry: * Register Images and Tags * Edit existing Images and Tags * Unregister Images Supports create, read and delete operations for: * Node Group Templates * Cluster Templates * Clusters No CLI support Implements blueprint python-savannaclient Change-Id: If0b7c4fb9660d646cb37c4b224bdcf39dc61bb19
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..dcb094b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+# vim: tabstop=4 shiftwidth=4 softtabstop=4
+
+# Copyright (c) 2013 Mirantis Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+import setuptools
+
+
+setuptools.setup(
+ setup_requires=[
+ 'd2to1>=0.2.10,<0.3',
+ 'pbr>=0.5,<0.6'
+ ],
+ d2to1=True
+)