summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:55 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:55 +0000
commitde6ea9d4ac1599bbb23e65dc6a7a70361ab47534 (patch)
tree6a9f91943de56a7062a557b7b82128d9f2b034bd /setup.py
parentb9a6e8b27d5960e8b68f9440983928dae7b0d109 (diff)
downloadpython-saharaclient-de6ea9d4ac1599bbb23e65dc6a7a70361ab47534.tar.gz
Updated from global requirements
Change-Id: Ia8206a2154e4cf57c4a520e54d60ecc295b884b7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)