summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-04 17:11:37 +0200
committerLuigi Toscano <ltoscano@redhat.com>2020-04-07 14:51:08 +0200
commit830d4607c3f20910c5a044ab5aa4d91e6bdb042a (patch)
tree68830e1248f2364a11510f73205e47f383692103 /setup.py
parentcca4f4d0c8a33a776e17413f5fda94c088b6a233 (diff)
downloadpython-saharaclient-830d4607c3f20910c5a044ab5aa4d91e6bdb042a.tar.gz
Cleanup py27 supportussuri-em3.1.0
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Add requires on python >= 3.6 to setup.cfg so that pypi and pip know about the requirement - Remove obsolete sections from setup.cfg: * Wheel is not needed for python 3 only repo * Some other sections are obsolete - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I95a49a2941790e0df1fde38f253ba2516959ce80
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d844..cd35c3c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)