summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2013-02-09 15:36:08 -0500
committerMark McLoughlin <markmc@redhat.com>2013-02-09 17:32:02 -0500
commit9805067bcf156dac354644b9b97ff8ceb4b5b3c6 (patch)
tree395f2de80fd32d0ac1d8c41b3442385719ec4d1a /setup.py
parentf24575c137abd204d5145ff59ae6e2fafc635a73 (diff)
downloadoslo-config-9805067bcf156dac354644b9b97ff8ceb4b5b3c6.tar.gz
Add sphinx documentation
Add basic sphinx config and copy the theming from oslo-incubator which was originally copied from keystone. Change-Id: Ibb3b679ce6e160c157ff63f0943807bd82aa1a67
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9384564..7ef2eac 100644
--- a/setup.py
+++ b/setup.py
@@ -42,8 +42,9 @@ setuptools.setup(
author_email='openstack-dev@lists.openstack.org',
url='http://www.openstack.org/',
license='Apache Software License',
- packages=['oslo.config', 'tests'],
+ packages=['oslo'],
namespace_packages=['oslo'],
+ cmdclass=setup.get_cmdclass(),
install_requires=requires,
tests_require=tests_require,
dependency_links=depend_links,