diff options
author | Vishvananda Ishaya <vishvananda@gmail.com> | 2012-01-18 21:04:47 -0800 |
---|---|---|
committer | Vishvananda Ishaya <vishvananda@gmail.com> | 2012-01-24 15:10:34 -0800 |
commit | 0c5273c85ea72d60e5907acb22398584ded0a077 (patch) | |
tree | 63b821532294db92763db5e849cf1b82637424ee /setup.py | |
parent | 30a40db708b84b767314a9f455e68f8175f89bb2 (diff) | |
download | nova-0c5273c85ea72d60e5907acb22398584ded0a077.tar.gz |
Create nova cert worker for x509 support
* Adds new worker for cert management
* Makes decrypt use an rpc to the worker
* Moves CA filesystem creation out of cloud.setup
* Moves test for X509 into crypto
* Adds test for encrypting and decrypting using cert
* Cleans up extra code in cloudpipe
* Fixes bug 918563
* Prepares for a future patch that will fix bug 903345
Change-Id: I4693c50c8f432706f97395af39e736f49d60e719
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -89,6 +89,7 @@ setup(name='nova', 'bin/nova-api-metadata', 'bin/nova-api-os-compute', 'bin/nova-api-os-volume', + 'bin/nova-cert', 'bin/nova-compute', 'bin/nova-console', 'bin/nova-consoleauth', |