diff options
author | Monty Taylor <mordred@inaugust.com> | 2012-06-24 17:32:31 -0500 |
---|---|---|
committer | Monty Taylor <mordred@inaugust.com> | 2012-06-28 07:42:48 -0700 |
commit | 204a42c76fe1d5af0a0036da436871aa2e442060 (patch) | |
tree | 06b0df22070429661b5541560f973f567c7da67c /setup.py | |
parent | 258f26fc79a85af800aace1bedd558057ba42177 (diff) | |
download | nova-204a42c76fe1d5af0a0036da436871aa2e442060.tar.gz |
Use setuptools-git plugin for MANIFEST.
Instead of a hard-coded MANIFEST.in to list non-code files to be included in
the tarball, use the setuptools-git plugin to ensure that every file that's
in git will wind up in the tarball. The only things needed in MANIFEST.in
now are files that are generated as part of the sdist run.
Change-Id: I76df685d58f7b56977d859e8df92e845f450b3e4
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -72,6 +72,7 @@ setuptools.setup(name='nova', packages=setuptools.find_packages(exclude=['bin', 'smoketests']), include_package_data=True, test_suite='nose.collector', + setup_requires=['setuptools_git>=0.4'], scripts=['bin/nova-all', 'bin/nova-api', 'bin/nova-api-ec2', |