summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:43:45 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:43:45 +0000
commitc393343593e7acb5158cede4fc58a130f35ddcca (patch)
treec92f6a4fab2831e2fc0ccce7486064dbd4fcfafc /setup.py
parent64bfdb6ad4c306a5ae96257121fd4699a422137e (diff)
downloadnova-c393343593e7acb5158cede4fc58a130f35ddcca.tar.gz
Updated from global requirements
Change-Id: Ia7fe0408883476b40dd0667fd6f56f5d068ca03f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f32b..736375744d 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)