summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McClain <mark.mcclain@dreamhost.com>2013-02-24 07:55:06 -0500
committerMark McClain <mark.mcclain@dreamhost.com>2013-02-27 21:49:57 -0500
commitf8de8c4450ab0d8483ccfcfcca48e21fea71c637 (patch)
tree3b67a9f198d0c8ec8e1992f5af8275a0f380c442 /setup.py
parent6f833c83284fc50ee62e729a8102badcfa5974d8 (diff)
downloadneutron-f8de8c4450ab0d8483ccfcfcca48e21fea71c637.tar.gz
LBaaS Agent Reference Implementation
implements blueprint lbaas-namespace-agent This a reference implemention of the Quantum load balancing service using HAProxy. The implemention is designed for vendors, developers, and deployers to become familiar with the API and service workflow. This change also adds some constraint checks for data integrity. Change-Id: I10a67da11840477ccf063b98149f4f77248802a1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e265ab2eca..ac701900a7 100644
--- a/setup.py
+++ b/setup.py
@@ -137,6 +137,8 @@ else:
'quantum-debug = quantum.debug.shell:main',
'quantum-ovs-cleanup = quantum.agent.ovs_cleanup_util:main',
'quantum-db-manage = quantum.db.migration.cli:main',
+ ('quantum-lbaas-agent = '
+ 'quantum.plugins.services.agent_loadbalancer.agent:main'),
('quantum-check-nvp-config = '
'quantum.plugins.nicira.nicira_nvp_plugin.check_nvp_config:main'),
]