summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Kukura <rkukura@redhat.com>2012-02-17 17:00:52 -0500
committerBob Kukura <rkukura@redhat.com>2012-02-17 17:55:00 -0500
commitd6bf2b76162ba806b2ad1f636f6273e47e03a117 (patch)
tree4466557375eb63d564dfac8a89a2f1575c1d54e5 /setup.py
parent04d144ae0b2ad5618847d1784cea48a08d53a46a (diff)
downloadneutron-d6bf2b76162ba806b2ad1f636f6273e47e03a117.tar.gz
Cleanup the source distribution.
Missing text files such as LICENSE and various READMEs are now included in the tarball source distribution. The Makefile and shell script for installing the openvswitch agent on xen are also now included. The openvswitch and linuxbridge agents are included, and executable wrapper scripts for the agents are provided. The cisco and linuxbridge nova drivers are now setup to be run from the quantum namespace rather than copied to nova. Finally, the setup_*.py scripts have been removed from the project. Fixes bug 925074. Test by running "python setup.py sdist" and examining the generated tarball. Change-Id: I33d336a5eb13678e6d527b575958393b337b6f3d Signed-off-by: Bob Kukura <rkukura@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 788be9f26b..dace785c61 100644
--- a/setup.py
+++ b/setup.py
@@ -106,6 +106,10 @@ setup(
eager_resources=EagerResources,
entry_points={
'console_scripts': [
+ 'quantum-linuxbridge-agent = \
+quantum.plugins.linuxbridge.agent.linuxbridge_quantum_agent:main',
+ 'quantum-openvswitch-agent = \
+quantum.plugins.openvswitch.agent.ovs_quantum_agent:main',
'quantum-server = quantum.server:main',
]
},