diff options
author | OpenStack Proposal Bot <openstack-infra@lists.openstack.org> | 2014-05-30 16:26:25 +0000 |
---|---|---|
committer | OpenStack Proposal Bot <openstack-infra@lists.openstack.org> | 2014-05-30 16:26:25 +0000 |
commit | 8e50e668107c3b15c7f3028e7ca20a4c04868452 (patch) | |
tree | b92878a993f3e0952106226e6ea484ed5d098196 /setup.py | |
parent | 35568575bb2dcced6e7190322c09e8637c432668 (diff) | |
download | keystone-8e50e668107c3b15c7f3028e7ca20a4c04868452.tar.gz |
Updated from global requirements
Change-Id: I413514eb61579dabac22909e30b8e86aca0b3a0e
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -17,6 +17,14 @@ # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT import setuptools +# In python < 2.7.4, a lazy loading of package `pbr` will break +# setuptools if some other modules registered functions in `atexit`. +# solution from: http://bugs.python.org/issue15881#msg170215 +try: + import multiprocessing # noqa +except ImportError: + pass + setuptools.setup( setup_requires=['pbr'], pbr=True) |