summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 05:25:27 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 05:25:27 +0000
commitacd0ad5acd9cf902e346c3f45bba1577c064c923 (patch)
tree5002aaaad908fa58d13c96089be4685d35ecaf72 /setup.py
parent6be126ec98a1af2a63b801aa1ec13140855b756d (diff)
downloadironic-acd0ad5acd9cf902e346c3f45bba1577c064c923.tar.gz
Updated from global requirements
Change-Id: I0eeaec761268fc4bc142939e191026c0411c162b
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f32..736375744 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)