summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMark McLoughlin <markmc@redhat.com>2013-02-18 17:13:52 +0000
committerMark McLoughlin <markmc@redhat.com>2013-02-18 17:27:14 +0000
commit150d2ca694af16542a0a7c13cb857cbdae98243c (patch)
tree7a6adbe8833bbab3804596fe4acc190616bc63e5 /setup.py
parentd22734c32600fbe121a50734e2ee30bf7bdf15ad (diff)
downloadheat-150d2ca694af16542a0a7c13cb857cbdae98243c.tar.gz
Use oslo-config-2013.1b3
The cfg API is now available via the oslo-config library, so switch to it and remove the copied-and-pasted version. Add the 2013.1b3 tarball to tools/pip-requires - this will be changed to 'oslo-config>=2013.1' when oslo-config is published to pypi. This will happen in time for grizzly final. Add dependency_links to setup.py so that oslo-config can be installed from the tarball URL specified in pip-requires. Remove the 'deps = pep8==1.3.4' from tox.ini as it means all the other deps get installed with easy_install which can't install oslo-config from the URL. Excluded code from oslo-incubator in the pep8 check. Retain dummy cfg.py file until keystoneclient middleware has been updated (I18c450174277c8e2d15ed93879da6cd92074c27a). Change-Id: I4815aeb8a9341a31a250e920157f15ee15cfc5bc
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 33bcb9373..fcded42dc 100755
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@ import setuptools
from heat.openstack.common import setup
requires = setup.parse_requirements()
+depend_links = setup.parse_dependency_links()
project = 'heat'
@@ -34,6 +35,7 @@ setuptools.setup(
packages=setuptools.find_packages(exclude=['bin']),
include_package_data=True,
install_requires=requires,
+ dependency_links=depend_links,
classifiers=[
'Development Status :: 4 - Beta',
'License :: OSI Approved :: Apache Software License',