diff options
author | Monty Taylor <mordred@inaugust.com> | 2013-05-16 09:27:55 -0700 |
---|---|---|
committer | Monty Taylor <mordred@inaugust.com> | 2013-05-25 08:35:00 +0200 |
commit | 05b97f368ec20c550f90fdcdc138592af69b7c50 (patch) | |
tree | 37fbd10997ad716f4e4688f175032d445df8adbc /setup.py | |
parent | 3eafb93e6846805b541e9fd5b30bb03d024b0d89 (diff) | |
download | heat-05b97f368ec20c550f90fdcdc138592af69b7c50.tar.gz |
Migrate to pbr.
Fixes bug 1179007
Change-Id: I698d02a2171e43237094c0e5ccc4c2dd47ed722b
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 43 |
1 files changed, 4 insertions, 39 deletions
@@ -1,4 +1,5 @@ -#!/usr/bin/python +#!/usr/bin/env python +# Copyright (c) 2013 Hewlett-Packard Development Company, L.P. # # Licensed under the Apache License, Version 2.0 (the "License"); # you may not use this file except in compliance with the License. @@ -15,42 +16,6 @@ import setuptools -from heat.openstack.common import setup - -requires = setup.parse_requirements() -depend_links = setup.parse_dependency_links() -project = 'heat' - - setuptools.setup( - name=project, - version=setup.get_version(project, '2013.2'), - description='The heat project provides services for provisioning ' - 'virtual machines', - license='Apache License (2.0)', - author='Heat API Developers', - author_email='discuss@heat-api.org', - url='http://heat.openstack.org/', - cmdclass=setup.get_cmdclass(), - packages=setuptools.find_packages(exclude=['bin']), - include_package_data=True, - install_requires=requires, - dependency_links=depend_links, - classifiers=[ - 'Development Status :: 4 - Beta', - 'License :: OSI Approved :: Apache Software License', - 'Operating System :: POSIX :: Linux', - 'Programming Language :: Python :: 2.6', - 'Environment :: No Input/Output (Daemon)', - ], - scripts=['bin/heat-cfn', - 'bin/heat-api', - 'bin/heat-api-cfn', - 'bin/heat-api-cloudwatch', - 'bin/heat-boto', - 'bin/heat-engine', - 'bin/heat-watch', - 'bin/heat-db-setup', - 'bin/cinder-keystone-setup', - 'bin/heat-keystone-setup'], - py_modules=[]) + setup_requires=['d2to1>=0.2.10,<0.3', 'pbr>=0.5.10,<0.6'], + d2to1=True) |