summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordtucker <dtucker>2008-06-08 20:17:53 +0000
committerdtucker <dtucker>2008-06-08 20:17:53 +0000
commitf7157a59be98759fe706a34394c2808af6bc8f9c (patch)
tree2da76d02d5209d8add9d74ebd4a16042be5697b9 /configure.ac
parent2d0497c0822c25d2c29296a7263a510a3f450b52 (diff)
downloadopenssh-f7157a59be98759fe706a34394c2808af6bc8f9c.tar.gz
- (dtucker) [configure.ac defines.h sftp-client.c M sftp-server.c] Add a
macro to convert fsid to unsigned long for platforms where fsid is a 2-member array.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4f3ec2a2..9f39b233 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.401 2008/06/08 17:32:29 dtucker Exp $
+# $Id: configure.ac,v 1.402 2008/06/08 20:17:53 dtucker Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.401 $)
+AC_REVISION($Revision: 1.402 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -3026,6 +3026,16 @@ if test "x$ac_cv_have_accrights_in_msghdr" = "xyes" ; then
file descriptor passing])
fi
+AC_MSG_CHECKING(if f_fsid has val members)
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/statvfs.h>],
+[struct fsid_t t; t.val[0] = 0;],
+ [ AC_MSG_RESULT(yes)
+ AC_DEFINE(FSID_HAS_VAL, 1, f_fsid has members) ],
+ [ AC_MSG_RESULT(no) ]
+)
+
AC_CACHE_CHECK([for msg_control field in struct msghdr],
ac_cv_have_control_in_msghdr, [
AC_COMPILE_IFELSE(