summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormouring <mouring>2002-04-05 16:11:45 +0000
committermouring <mouring>2002-04-05 16:11:45 +0000
commit501611b856e349a4b2c99705480424d27e8b93fe (patch)
treedfbc3c63037c4a8066e62c1e38b1497104baccd1 /configure.ac
parenta7090c50a8e48a7b7599960971b9c4388dda3407 (diff)
downloadopenssh-501611b856e349a4b2c99705480424d27e8b93fe.tar.gz
- (bal) Patch for OpenSC SmartCard library; ok markus@; patch by
Juha Yrjölä <jyrjola@cc.hut.fi> - (bal) Minor documentation update to reflect smartcard library support changes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 37 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 09607b07..6bd29254 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.30 2002/03/31 19:23:07 tim Exp $
+# $Id: configure.ac,v 1.31 2002/04/05 16:11:46 mouring Exp $
AC_INIT
AC_CONFIG_SRCDIR([ssh.c])
@@ -1667,11 +1667,11 @@ if test "x$ac_cv_libc_defines_sys_nerr" = "xyes" ; then
AC_DEFINE(HAVE_SYS_NERR)
fi
-
-# Check whether user wants Kerberos support
SCARD_MSG="no"
-AC_ARG_WITH(smartcard,
- [ --with-smartcard Enable smartcard support],
+
+# Check whether user wants sectok support
+AC_ARG_WITH(sectok,
+ [ --with-sectok Enable smartcard support using libsectok],
[
if test "x$withval" != "xno" ; then
if test "x$withval" != "xyes" ; then
@@ -1693,7 +1693,38 @@ AC_ARG_WITH(smartcard,
AC_MSG_ERROR(Can't find libsectok)
fi
AC_DEFINE(SMARTCARD)
- SCARD_MSG="yes"
+ AC_DEFINE(USE_SECTOK)
+ SCARD_MSG="yes, using sectok"
+ fi
+ ]
+)
+
+# Check whether user wants OpenSC support
+AC_ARG_WITH(opensc,
+ [ --with-opensc Enable smartcard support using OpenSC],
+ [
+ if test "x$withval" != "xno" ; then
+ if test "x$withval" != "xyes" ; then
+ CPPFLAGS="$CPPFLAGS -I${withval}"
+ LDFLAGS="$LDFLAGS -L${withval}"
+ if test ! -z "$need_dash_r" ; then
+ LDFLAGS="$LDFLAGS -R${withval}"
+ fi
+ if test ! -z "$blibpath" ; then
+ blibpath="$blibpath:${withval}"
+ fi
+ fi
+ AC_CHECK_HEADERS(opensc-pkcs15.h)
+ if test "$ac_cv_header_opensc_pkcs15_h" != yes; then
+ AC_MSG_ERROR(Can't find opensc-pkcs15.h)
+ fi
+ AC_CHECK_LIB(opensc, sc_pkcs15_bind)
+ if test "$ac_cv_lib_opensc_sc_pkcs15_bind" != yes; then
+ AC_MSG_ERROR(Can't find libopensc)
+ fi
+ AC_DEFINE(SMARTCARD)
+ AC_DEFINE(USE_OPENSC)
+ SCARD_MSG="yes, using OpenSC"
fi
]
)