summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordjm <djm>2010-02-09 23:19:29 +0000
committerdjm <djm>2010-02-09 23:19:29 +0000
commit32a958fabf7c9ae43fad3b856320ac1c16f5c246 (patch)
tree9df0c05676e112230897261617ad61e033be6ea9 /configure.ac
parenta674eef1c7e631135a24e89560bb23842f2c78fb (diff)
downloadopenssh-32a958fabf7c9ae43fad3b856320ac1c16f5c246.tar.gz
- (djm) add -lselinux to LIBS before calling AC_CHECK_FUNCS for
getseuserbyname; patch from calebcase AT gmail.com via cjwatson AT debian.org
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e5de6f58..5fc1d4a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# $Id: configure.ac,v 1.439 2010/01/22 18:25:15 tim Exp $
+# $Id: configure.ac,v 1.440 2010/02/09 23:19:29 djm Exp $
#
# Copyright (c) 1999-2004 Damien Miller
#
@@ -15,7 +15,7 @@
# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
-AC_REVISION($Revision: 1.439 $)
+AC_REVISION($Revision: 1.440 $)
AC_CONFIG_SRCDIR([ssh.c])
AC_CONFIG_HEADER(config.h)
@@ -3413,9 +3413,12 @@ AC_ARG_WITH(selinux,
AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
SELINUX_MSG="yes"
AC_CHECK_HEADER([selinux/selinux.h], ,
- AC_MSG_ERROR(SELinux support requires selinux.h header))
- AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
- AC_MSG_ERROR(SELinux support requires libselinux library))
+ AC_MSG_ERROR(SELinux support requires selinux.h header))
+ AC_CHECK_LIB(selinux, setexeccon,
+ [ LIBSELINUX="-lselinux"
+ LIBS="$LIBS -lselinux"
+ ],
+ AC_MSG_ERROR(SELinux support requires libselinux library))
SSHDLIBS="$SSHDLIBS $LIBSELINUX"
AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
LIBS="$save_LIBS"