summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwchang0222%aol.com <devnull@localhost>2004-10-06 00:52:57 +0000
committerwchang0222%aol.com <devnull@localhost>2004-10-06 00:52:57 +0000
commit5901a3a182466af97c9a46e851ffd208bd939967 (patch)
treede1be365f286d745b8e9560010492069327fa331 /configure.in
parent288012736da46203e52919dbdfcb6b6f23b734d3 (diff)
downloadnspr-hg-5901a3a182466af97c9a46e851ffd208bd939967.tar.gz
Bugzilla bug 259001: ported NSPR to Solaris on AMD64 architecture. The
patch is contributed by Julien Pierre <julien.pierre.bugs@sun.com>. r=wtc. Modified Files: configure configure.in _solaris.h _solaris64.cfg Added Files: os_SunOS_x86_64.s
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 22 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index a9ef3c2b..8a3fcce0 100644
--- a/configure.in
+++ b/configure.in
@@ -1682,9 +1682,6 @@ mips-sony-newsos*)
DSO_CFLAGS=-KPIC
DSO_LDOPTS='-G -h $(notdir $@) -z combreloc -z defs'
fi
- if test -z "$GNU_AS"; then
- ASFLAGS="$ASFLAGS -Wa,-P"
- fi
if test -n "$GNU_CC"; then
CFLAGS="$CFLAGS -Wall"
CXXFLAGS="$CXXFLAGS -Wall"
@@ -1692,6 +1689,10 @@ mips-sony-newsos*)
CFLAGS="$CFLAGS -MDupdate \$(DEPENDENCIES)"
CXXFLAGS="$CXXFLAGS -MDupdate \$(DEPENDENCIES)"
fi
+ GCC_AS=`$CC -print-prog-name=as`
+ if test "`echo | $GCC_AS -v 2>&1 | grep -c GNU`" != "0"; then
+ GNU_AS=1
+ fi
else
CFLAGS="$CFLAGS -xstrconst"
CXXFLAGS="$CXXFLAGS -Qoption cg -xstrconst -features=tmplife"
@@ -1701,17 +1702,27 @@ mips-sony-newsos*)
fi
_OPTIMIZE_FLAGS=-xO4
fi
+ if test -z "$GNU_AS"; then
+ ASFLAGS="$ASFLAGS -Wa,-P"
+ fi
if test -n "$USE_64"; then
if test -n "$GNU_CC"; then
CC="$CC -m64"
CXX="$CXX -m64"
else
- CC="$CC -xarch=v9"
- CXX="$CXX -xarch=v9"
+ if test "$OS_TEST" = "i86pc"; then
+ CC="$CC -xarch=amd64"
+ CXX="$CXX -xarch=amd64"
+ else
+ CC="$CC -xarch=v9"
+ CXX="$CXX -xarch=v9"
+ fi
fi
fi
if test "$OS_TEST" = "i86pc"; then
- AC_DEFINE(i386)
+ if test -z "$USE_64"; then
+ AC_DEFINE(i386)
+ fi
CPU_ARCH_TAG=_$OS_TEST
# The default debug format, DWARF (-g), is not supported by gcc
# on i386-ANY-sysv4/solaris, but the stabs format is. It is
@@ -2346,7 +2357,11 @@ case "$target" in
AC_DEFINE(_REENTRANT)
AC_DEFINE(HAVE_POINTER_LOCALTIME_R)
if test "$OS_TEST" = "i86pc"; then
- PR_MD_ASFILES=os_SunOS_x86.s
+ if test -n "$USE_64"; then
+ PR_MD_ASFILES=os_SunOS_x86_64.s
+ else
+ PR_MD_ASFILES=os_SunOS_x86.s
+ fi
else
PR_MD_ASFILES=os_SunOS.s
if test -n "$USE_64"; then