summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwtc%netscape.com <devnull@localhost>2001-05-21 22:55:09 +0000
committerwtc%netscape.com <devnull@localhost>2001-05-21 22:55:09 +0000
commit704010f4c3b5d4ab05e25bd55070a0701683404b (patch)
tree0bd9bb965c152795b359553849e897fa0597e5b1 /configure.in
parent54f4d87c322fd77fec9ee594315c318e8093f53c (diff)
downloadnspr-hg-704010f4c3b5d4ab05e25bd55070a0701683404b.tar.gz
On Linux, use $(CC) to link the shared library. Define _REENTRANT in just
one place for Solaris. Use the null command : instead of 'true'. Modified files: configure.in, configure.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 454507ff..e14f3e4b 100644
--- a/configure.in
+++ b/configure.in
@@ -1027,9 +1027,9 @@ case "$target" in
CXXFLAGS="$CXXFLAGS -ansi -Wall -pipe"
MDCPUCFG_H=_linux.cfg
PR_MD_CSRCS=linux.c
- MKSHLIB='$(LD) $(DSO_LDOPTS) -soname $(notdir $@) -o $@'
+ MKSHLIB='$(CC) $(DSO_LDOPTS) -o $@'
DSO_CFLAGS=-fPIC
- DSO_LDOPTS=-shared
+ DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
OS_LIBS="$OS_LIBS -lc"
_OPTIMIZE_FLAGS=-O2
case "${target_cpu}" in
@@ -1933,7 +1933,6 @@ if test -n "$USE_PTHREADS"; then
case "$target" in
*-solaris*)
- AC_DEFINE(_REENTRANT)
if test "$ac_cv_have_dash_pthreads" = "yes"; then
_PTHREAD_LDFLAGS=
fi
@@ -2043,7 +2042,7 @@ case "$target" in
fi
if test -n "$USE_PTHREADS"; then
if echo $OS_RELEASE | egrep -c '(V2.0|V3.2)' 2>/dev/null; then
- true
+ :
else
AC_DEFINE(_PR_HAVE_THREADSAFE_GETHOST)
fi