summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2020-08-19 21:36:52 +0200
committerNiels Möller <nisse@lysator.liu.se>2020-08-26 18:13:51 +0200
commit4b9e015cc935b6ad1701f8399218e9325adccbfa (patch)
tree763792dc255661c61dceb96f40ef572ed890a26b /configure.ac
parent98d60d7ff1eef8953c086fd535edaa4969a0a5b1 (diff)
downloadnettle-4b9e015cc935b6ad1701f8399218e9325adccbfa.tar.gz
Add support for powerpc64 fat build
Based on patch by Mamone Tarsha
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c4e9b304..0e4b41f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,8 +446,12 @@ if test "x$enable_assembler" = xyes ; then
fi
;;
*powerpc64*)
- if test "x$enable_power_crypto_ext" = xyes ; then
- asm_path="powerpc64/p8 powerpc64"
+ asm_path="powerpc64"
+ if test "x$enable_fat" = xyes ; then
+ asm_path="powerpc64/fat $asm_path"
+ OPT_NETTLE_SOURCES="fat-ppc.c $OPT_NETTLE_SOURCES"
+ elif test "x$enable_power_crypto_ext" = xyes ; then
+ asm_path="powerpc64/p8 $asm_path"
fi
;;