summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-03-17 13:12:13 +0100
committerNiels Möller <nisse@lysator.liu.se>2015-03-19 18:59:01 +0100
commit7bd822663cb4bf98c5a91f4e755cf3c0924b0193 (patch)
tree0d94fcade02dc6a61b3c6fbc9e23db53c4449733 /configure.ac
parent0d66c601ee79bae8d8b175ad7dd0f0e8d5e56c45 (diff)
downloadnettle-7bd822663cb4bf98c5a91f4e755cf3c0924b0193.tar.gz
Added version.h with library versioning information
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 51ab3b34..56f69097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,11 @@ LIBNETTLE_MINOR=0
LIBHOGWEED_MAJOR=4
LIBHOGWEED_MINOR=0
+MAJOR_VERSION=`echo $PACKAGE_VERSION | sed 's/\(.*\)\..*/\1/g'`
+MINOR_VERSION=`echo $PACKAGE_VERSION | sed 's/.*\.\(.*\)/\1/g'`
+AC_SUBST([MAJOR_VERSION])
+AC_SUBST([MINOR_VERSION])
+
AC_CANONICAL_HOST
# Command line options
@@ -895,7 +900,7 @@ if test x$GCC = xyes ; then
# inttypes.h.
fi
-AC_CONFIG_FILES([config.make config.m4 Makefile bignum.h])
+AC_CONFIG_FILES([config.make config.m4 Makefile bignum.h version.h])
AC_CONFIG_FILES([tools/Makefile testsuite/Makefile examples/Makefile])
AC_CONFIG_FILES([nettle.pc hogweed.pc libnettle.map libhogweed.map])