summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Möller <nisse@lysator.liu.se>2021-08-06 11:07:56 +0200
committerNiels Möller <nisse@lysator.liu.se>2021-08-06 11:07:56 +0200
commitf670f85de5784bf8b67c56b09852dfb90d26b7f2 (patch)
tree7a358934fe508672112e45623c9d41673f79423d /configure.ac
parent2c59a6434f3c4d594f06a7875d503726694de381 (diff)
parentb8054a1d0ad507812da9ba946a70d81100086252 (diff)
downloadnettle-f670f85de5784bf8b67c56b09852dfb90d26b7f2.tar.gz
Merge branch 'mamonet/nettle-s390x-memxor' into master-updates
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 44add732..546cd1b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,10 @@ AC_ARG_ENABLE(power-altivec,
AC_HELP_STRING([--enable-power-altivec], [Enable POWER altivec and vsx extensions. (default=no)]),,
[enable_altivec=no])
+AC_ARG_ENABLE(s390x-vf,
+ AC_HELP_STRING([--enable-s390x-vf], [Enable vector facility on z/Architecture. (default=no)]),,
+ [enable_s390x_vf=no])
+
AC_ARG_ENABLE(s390x-msa,
AC_HELP_STRING([--enable-s390x-msa], [Enable message-security assist extensions on z/Architecture. (default=no)]),,
[enable_s390x_msa=no])
@@ -533,8 +537,11 @@ if test "x$enable_assembler" = xyes ; then
if test "x$enable_fat" = xyes ; then
asm_path="s390x/fat $asm_path"
OPT_NETTLE_SOURCES="fat-s390x.c $OPT_NETTLE_SOURCES"
- FAT_TEST_LIST="none msa_x1 msa_x2 msa_x4"
+ FAT_TEST_LIST="none vf msa_x1 msa_x2 msa_x4"
else
+ if test "$enable_s390x_vf" = yes ; then
+ asm_path="s390x/vf $asm_path"
+ fi
if test "$enable_s390x_msa" = yes ; then
asm_path="s390x/msa_x1 s390x/msa_x2 s390x/msa_x4 $asm_path"
fi
@@ -567,7 +574,7 @@ asm_replace_list="aes-encrypt-internal.asm aes-decrypt-internal.asm \
# Assembler files which generate additional object files if they are used.
asm_nettle_optional_list="gcm-hash.asm gcm-hash8.asm cpuid.asm cpu-facility.asm \
- aes-encrypt-internal-2.asm aes-decrypt-internal-2.asm memxor-2.asm \
+ aes-encrypt-internal-2.asm aes-decrypt-internal-2.asm memxor-2.asm memxor3-2.asm \
aes128-set-encrypt-key-2.asm aes128-set-decrypt-key-2.asm \
aes128-encrypt-2.asm aes128-decrypt-2.asm \
aes192-set-encrypt-key-2.asm aes192-set-decrypt-key-2.asm \
@@ -680,6 +687,7 @@ AC_SUBST([ASM_PPC_WANT_R_REGISTERS])
AH_VERBATIM([HAVE_NATIVE],
[/* Define to 1 each of the following for which a native (ie. CPU specific)
implementation of the corresponding routine exists. */
+#undef HAVE_NATIVE_memxor3
#undef HAVE_NATIVE_aes_decrypt
#undef HAVE_NATIVE_aes_encrypt
#undef HAVE_NATIVE_aes128_decrypt