summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Leske <sebastian.leske@sleske.name>2017-09-22 22:12:23 +0200
committerSebastian Leske <sebastian.leske@sleske.name>2017-09-22 22:13:44 +0200
commite090bdd6708871523a221f74f6d056cc0db36cf0 (patch)
tree7b5e3176f331780465efae4d2265d0cde66b4955 /CMakeLists.txt
parent4fd96b2cb6ff58334f7085af416b4376e2519818 (diff)
downloadnavit-e090bdd6708871523a221f74f6d056cc0db36cf0.tar.gz
Fix:build:Add -Wformat-security
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d5924582..d3d764d36 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -795,7 +795,8 @@ if(CMAKE_COMPILER_IS_GNUCC OR CCMAKE_COMPILER_IS_GNUCXX)
add_compiler_flag_if_available("-Wno-missing-field-initializers")
add_compiler_flag_if_available("-Wextra")
add_compiler_flag_if_available("-Wmissing-prototypes")
- add_compiler_flag_if_available("-Wstrict-prototypes ")
+ add_compiler_flag_if_available("-Wstrict-prototypes")
+ add_compiler_flag_if_available("-Wformat-security")
endif()
if (EXTRA_DEFINES)