summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2003-09-01 04:19:37 +0000
committerH. Peter Anvin <hpa@zytor.com>2003-09-01 04:19:37 +0000
commit2ef2f06125e19f57d5366c8fe4210deaa3e5bfd4 (patch)
treeb53727bd8f43931c7a0e798b0f6b2198da282d44 /configure.in
parentbdf061f6e72e6d2fadc5890c1d86d5b8efd6768a (diff)
downloadnasm-2ef2f06125e19f57d5366c8fe4210deaa3e5bfd4.tar.gz
Enable the use of a config.h file and autoheader. At this point we don't
actually *use* the resulting configuration file, but it keeps autoconf from creating an insanely long compiler command line, which can cause problems all by itself. Eventually we can do: #ifdef HAVE_CONFIG_H #include "config.h" #endif ... to get the same information.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 36ca7fac..5ab86962 100644
--- a/configure.in
+++ b/configure.in
@@ -3,6 +3,7 @@ dnl a configure script.
AC_PREREQ(2.53)
AC_REVISION([$Id$])
AC_INIT(nasm.c)
+AC_CONFIG_HEADERS(config.h)
dnl Check for broken VPATH handling on older NetBSD makes.
AC_DEFUN(AC_PROG_MAKE_VPATHOK,