summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2009-03-01 13:57:40 -0800
committerH. Peter Anvin <hpa@zytor.com>2009-03-01 13:57:40 -0800
commit1fb908c0dbf5bdde4d4aaaf78b48b6520d52de4c (patch)
treef4850a76f97b9bdfa7885f56bba70e2285a045c4 /configure.in
parent16a856cd851858f80b1ef407d77f92df309e5909 (diff)
downloadnasm-1fb908c0dbf5bdde4d4aaaf78b48b6520d52de4c.tar.gz
autoconf: detect the broken bool in OpenWatcom 1.8
OpenWatcom 1.8 has a C99 mode, which implements _Bool and <stdbool.h>. Unfortunately the implementation is broken, and doesn't let _Bool be implicitly converted to integer (as required by the C99 spec). Detect this case in autoconf.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0d536533..b47675be 100644
--- a/configure.in
+++ b/configure.in
@@ -97,6 +97,7 @@ AC_C_CONST
AC_C_INLINE
AC_C_RESTRICT
AC_TYPE_SIZE_T
+PA_WORKING_BOOL
AC_C_BIGENDIAN(AC_DEFINE(WORDS_BIGENDIAN),AC_DEFINE(WORDS_LITTLEENDIAN))
AH_TEMPLATE(WORDS_BIGENDIAN,
[Define to 1 if your processor stores words with the most significant