summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH. Peter Anvin <hpa@zytor.com>2002-05-19 02:26:38 +0000
committerH. Peter Anvin <hpa@zytor.com>2002-05-19 02:26:38 +0000
commit1170eb6546c6d5a950d171d203d3dbc148cca295 (patch)
treeac21f36c79fdb437770536d2698f9f88b5c55a83 /configure.in
parentb9f0510eb50c4e07863ad95b7af98bcb98d0b555 (diff)
downloadnasm-1170eb6546c6d5a950d171d203d3dbc148cca295.tar.gz
Check in the rest of the Cygwin support patch...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4903b4cf..36ca7fac 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,7 @@
-dnl Process this file with autoconf to produce a configure script.
+dnl Process this file with autoconf 2.53 or later to produce
+dnl a configure script.
+AC_PREREQ(2.53)
+AC_REVISION([$Id$])
AC_INIT(nasm.c)
dnl Check for broken VPATH handling on older NetBSD makes.
@@ -106,9 +109,9 @@ fi
if test $ac_cv_prog_make_vpathok = no; then
echo Copying generated srcs into build directory to compensate for VPATH breakage
- if test ! -f insnsa.c; then cp -p ${srcdir}/insnsa.c .; fi
- if test ! -f insnsd.c; then cp -p ${srcdir}/insnsd.c .; fi
- if test ! -f macros.c; then cp -p ${srcdir}/macros.c .; fi
+ for file in macros.c insnsa.c insnsd.c insnsn.c insnsi.h version.h version.mac; do
+ if test ! -f $file; then cp -p ${srcdir}/${file} .; fi
+ done
fi
AC_OUTPUT_COMMANDS([mkdir -p output])