summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2cec915e..d8edb4942 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,6 +29,12 @@ INCLUDES= \
-DMUTTER_PLUGIN_DIR=\"@MUTTER_PLUGIN_DIR@\" \
-DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\"
+if HAVE_WAYLAND
+INCLUDES += \
+ -I$(srcdir)/wayland \
+ -DXWAYLAND_PATH='"@XWAYLAND_PATH@"'
+endif
+
mutter_built_sources = \
mutter-enum-types.h \
mutter-enum-types.c