summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 96f53ddc4..777086801 100644
--- a/meson.build
+++ b/meson.build
@@ -396,11 +396,14 @@ if have_wayland
# For Xwayland -initfd usage
use_initfd = get_option('xwayland_initfd')
+ xwayland_options = run_command(xwayland_path, '-help')
if use_initfd.auto()
- xwayland_options = run_command(xwayland_path, '-help')
have_xwayland_initfd = xwayland_options.stderr().contains('-initfd')
else
have_xwayland_initfd = use_initfd.enabled()
+ if have_xwayland_initfd and not xwayland_options.stderr().contains('-initfd')
+ error('XWayland -initfd support requested but not available')
+ endif
endif
if (have_xwayland_initfd)