summaryrefslogtreecommitdiff
path: root/cogl/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cogl/configure.ac')
-rw-r--r--cogl/configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/cogl/configure.ac b/cogl/configure.ac
index 1ec4dbf10..1a447e7ed 100644
--- a/cogl/configure.ac
+++ b/cogl/configure.ac
@@ -657,7 +657,7 @@ AC_ARG_ENABLE(
[kms-egl-platform],
[AC_HELP_STRING([--enable-kms-egl-platform=@<:@no/yes@:>@], [Enable support for the KMS egl platform @<:@default=no@:>@])],
[],
- enable_kms_egl_platform=no
+ enable_kms_egl_platform=yes
)
AS_IF([test "x$enable_kms_egl_platform" = "xyes"],
[
@@ -690,7 +690,7 @@ AC_ARG_ENABLE(
[wayland-egl-server],
[AC_HELP_STRING([--enable-wayland-egl-server=@<:@no/yes@:>@], [Enable server side wayland support @<:@default=no@:>@])],
[],
- enable_wayland_egl_server=no
+ enable_wayland_egl_server=yes
)
AS_IF([test "x$enable_wayland_egl_server" = "xyes"],
[
@@ -711,10 +711,7 @@ AC_ARG_ENABLE(
[xlib-egl-platform],
[AC_HELP_STRING([--enable-xlib-egl-platform=@<:@no/yes@:>@], [Enable support for the Xlib egl platform @<:@default=auto@:>@])],
[],
- AS_IF([test "x$enable_gles1" = "xyes" -o \
- "x$enable_gles2" = "xyes" && \
- test $EGL_PLATFORM_COUNT -eq 0],
- [enable_xlib_egl_platform=yes], [enable_xlib_egl_platform=no])
+ enable_xlib_egl_platform=yes
)
AS_IF([test "x$enable_xlib_egl_platform" = "xyes"],
[