summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2019-07-24 07:42:07 +0200
committerCarlos Garnacho <mrgarnacho@gmail.com>2019-07-31 09:34:17 +0000
commitefe6c13d93f8a782d351440329e8d6a07ef06377 (patch)
tree775a730575d5252728e0b6ef8de80fee21cdfcbb /src/meson.build
parentaae9f3a3e64f7b3cfed45cfd531c740cb9e9ae71 (diff)
downloadmutter-efe6c13d93f8a782d351440329e8d6a07ef06377.tar.gz
cursor-tracker: Use our own marshal for cursor-moved
By putting `NULL` as the C marshaller in `g_signal_new`, you automatically get `g_cclosure_marshaller_generic`, which will try to process its arguments and return value with the help of libffi and GValue. Using `glib-genmarshal` and valist_marshallers, we can prevent this so that we need less instructions for each signal emission. https://gitlab.gnome.org/GNOME/mutter/merge_requests/697
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 515638fe5..e682aa4fd 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -657,6 +657,14 @@ dbus_idle_monitor_built_sources = gnome.gdbus_codegen('meta-dbus-idle-monitor',
)
mutter_built_sources += dbus_idle_monitor_built_sources
+mutter_marshal = gnome.genmarshal('meta-marshal',
+ sources: ['meta-marshal.list'],
+ prefix: 'meta_marshal',
+ internal: true,
+ valist_marshallers: true,
+ )
+mutter_built_sources += mutter_marshal
+
if have_profiler
mutter_sources += [
'backends/meta-profiler.c',