summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorArun Raghavan <arun@arunraghavan.net>2020-02-26 10:08:56 -0500
committerJonas Ã…dahl <jadahl@gmail.com>2020-02-26 15:37:00 +0000
commit6e7316ef11a03e6ccca8828dfc33dcc60af0061e (patch)
tree7b58c43c69f6baa9141388fae0710d17ead1f061 /src/meson.build
parent9fa56176fd5c95b609cc52b594baa47880961aa9 (diff)
downloadmutter-6e7316ef11a03e6ccca8828dfc33dcc60af0061e.tar.gz
build: Use dbus interface dir from pkg-config
Using 'datadir' breaks prefixed builds (as we look for interface files in the prefix we are going to install to). https://gitlab.gnome.org/GNOME/mutter/merge_requests/1094
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 31840d5bd..85f24e963 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -715,7 +715,7 @@ if have_profiler
'backends/meta-profiler.h',
]
- dbus_interfaces_dir = join_paths(datadir, 'dbus-1', 'interfaces')
+ dbus_interfaces_dir = dbus_dep.get_pkgconfig_variable('interfaces_dir')
sysprof3_dbus_file = join_paths(dbus_interfaces_dir, 'org.gnome.Sysprof3.Profiler.xml')
dbus_sysprof3_profiler_built_sources = gnome.gdbus_codegen('meta-dbus-sysprof3-profiler',